As of December 2018, Fnatic Gear are aware of a device detection issue on the software for the Flick G1 and Clutch G1 due to ongoing issues in the new Windows build 1809. There is a widespread issue in the Windows build 1809 and will have begun to show when upgrading Windows from 1803 to 1809, or by installing a new Windows OS directly to 1809. Microsoft have blocked updates to 1809 as a result of ongoing issues with this build.
Please see the article below regarding the upgrades blocks that are currently in place.
https://support.microsoft.com/en-gb/help/4464619/windows-10-update-history

For the time being, we recommended rolling back your software to 1803, or waiting until the issues of 1809 are fixed. Our developers are investigating the issue at hand, and hope to be able to find a software update resolve as soon as possible.

Thank you!

Did this answer your question?